0
Fixed

Refund transaction sets transaction_revenue to zero

Anders Ekelund 3 months ago in Analytics • updated 3 months ago 3

Hi!

I had an issue when trying to refund transactions in Analytics.

I could produce the request and copy to clipboard. 

So far so good.

But when reviewing the request I found that the transaction revenue parameter (tr) was set to zero (0).

The ts and tt parameters where negative as expected.

I also tried to do a refund without debug mode and the problem was the same. Transaction revenue was zero.

I assume this could be a bug since this article told me that the revenue parameter should be negative equivalent of the original transaction.
https://radical-analytics.com/reversing-refunding-google-analytics-transactions-with-da-vinci-tools-1e1a23ce5217

There was no error or warning in the chrome debug console.

Hope this helps and thanks for a great addon!


Best regards

Anders

0
Fixed

Refund transaction not working when HideMe is disabled

Anders Ekelund 3 months ago in Analytics • updated by Stéphane Hamel 3 months ago 4

Hi Stéphane!
First let me say that this feature is awesome. Just what i was looking for.

I think I found a bug though.

When I uncheck the "Hide Me" feature of the addon (for Analytics) It will fail to authenticate when I try to refund a transaction. The chrome console error points to that you are trying to get the UA-id from the HideMe element and when it is not there it fails.


From console:


From galaxy.js:

Cheers and thanks again for a great feature!

BR
Anders

    Answer
    Stéphane Hamel 3 months ago

    I fixed this - and I suspect this might have had a side effect on the other bug you reported. When building the revert/refund request, it does a GA Reporting API request to retrieve the transaction details. If the UA wasn't right to do the request, all amounts were likely 0 or there was a JS error and building the refund/revert request failed.

    0
    Declined

    Data studio: Jump into field editing from data overview

    Sander 3 months ago in Data Studio • updated by Stéphane Hamel 2 months ago 4

    Editing a custom field (metric) you currently have in use is a hassle! When you select the edit button you just get some display options. I need to click "Create new field" in the bottom right. Then from there do "All fields" then search for the field I want to edit, then i can edit it.

    For filters this UX is there. If you add a filter to a table/graph then when you hover over it in the list of filters there is a edit button and you edit that filter directly there. Custom fields (metrics) don't have this, they should!

    Answer
    Stéphane Hamel 2 months ago

    Well... sadly... after looking into it more carefully, there's no easy way to do it because the field element shown on the page doesn't have any indication if it's a custom field or not. I will park this for now but keep it as a potential feature in the future, once I have worked a little bit more on the more advanced modules which will bring subscribers value.

    0
    Fixed

    Can't access other logged profiles in GTM (Chrome) it always redirect to the default user

    Carlos Escalera 3 months ago in Tag Manager • updated by Stéphane Hamel 3 months ago 4

    I noticed this yesterday, when I was trying to switch to another logged user in Chrome, GTM kept redirecting me to the default user. I had to disable the extension momentarily to be able to change

    UPDATE: the issue disappears when I disable the option "RememberMe: Remember last container you were on"

    Answer
    Stéphane Hamel 3 months ago

    Fixed in the upcoming release.

    0
    Fixed

    Google Sheets Export - Not Exporting Segment or Filters

    TomScogg 4 months ago in Analytics • updated by Stéphane Hamel 4 months ago 3

    Hi,

    I've been using the Google Sheets Export option for the first time and I've noticed it does not include the segment i have applied or the filters that I've set in the report when I paste over to Google Sheets

    Is something broken or have I not exported it correctly?

    Cheers

    Answer
    Stéphane Hamel 4 months ago

    Good catch! I fixed it, and at the same time I found that some segment IDs listed in the GA interface do not actually match the reporting API segment ids.


    For example, All Users in the GA interface is "builtin1" and corresponds to "gaid::-1" in the reporting API, which is easy to handle. But Bounced Sessions is "builtin27" in the GA interface, but is "gaid::-19" for the reporting API... go figure!

    This will be fixed in the next release, coming up April 5th.

    0
    Fixed

    Google Analytics export tool is not responding

    Ethan Bartolic 4 months ago in Analytics • updated by Stéphane Hamel 4 months ago 5

    The custom export options Da Vinci provides are not responding. The mouse does not indicate that these are clickable elements and when clicked nothing happens. This is true of built-in and custom reports. I have tried disabling the feature and disabling Da Vinci.

    Answer
    Stéphane Hamel 4 months ago

    I just checked and the filters are there for dimensions and metrics, for Reporting API v4 and GA Spreadsheet addon. I also recorded a quick demo here: https://www.useloom.com/share/cb8100a272a0480788d4ace47f079e01

    While doing my test, I noticed the condition for metrics was there but with the wrong condition - for example, it had METRIC_GREATER_THAN instead of just GREATER_THAN. I just fixed that and it will be ok in the next release.

    If you still have issues, please check if there are any errors in your browser JavaScript console, or more info about the query you are trying to build (which report, which segments, filters, etc.) and I will see if I can reproduce it.

    0
    Answered

    Hide me does not work

    Paul H. 4 months ago in Analytics • updated 3 months ago 9

    I'm running into a problem that I cannot resolve and I can't find a posted description of the problem or the solution anywhere. I've my copy of the DaVinci in Google Analytics Tracking is set to "OFF" (Blocked).  When going to my website I see myself being tracked on GA "Real-time."  If I close the browser tab that I used to opened my website I continue to show up as a "real-time" user past the 30 second delayed response time.   If I close my Google Chrome browser, open it and the go directly to GA (nothing else), I'm still tracking as a real-time user. (?????)   The only way I found to remove myself from being tracked in real time on GA is to reboot my laptop. (????!!!!)   Got any ideas what could be causing this false real-time tracking??  Thank you....

    Answer
    Stéphane Hamel 4 months ago

    I just checked again - worked fine for me. I also did a little Loom screen recording to show how it works/what happens: https://www.useloom.com/share/2781aa4b0a254c76a55ceeaa125598db

    • make sure you are NOT in Incognito mode - to respect user's privacy, Da Vinci doesn't work when the browser is in Incognito
    • does the Da Vinci Tools icon in the browser toolbar show a little red X?
    • if you can share your website, I can try to see if for some odd reason the GA call isn't being detected (you can email me@StephaneHamel.net to share the details)
    • if you open the browser JavaScript console, are there any errors?
    • if you enter chrome:extensions in your browser URL bar, it will show all your extensions and you can click on the background page for Da Vinci Tools - you will see messages like this:
    Analytics.HideMe: Set to /id=(UA-570276-22)/
    Analytics.HideMe: Blocked POST request matching /id=(UA-570276-22)/
    Analytics.HideMe: Blocked GET request matching /id=(UA-570276-22)/
    Analytics.HideMe: Set to /id=(^$)/
    0
    Completed

    Conditional style formatting in datastudio

    Alrik Burger 5 months ago • updated 5 months ago 5

    To me datastudio is currently lacking proper conditional formating of metrics.

    Is it possible to fix this with da vinci tools. It would be great for some metrcis to have the basic possibility to maken the color of numbers red for negatives and green for positives for example.

    Answer
    Stéphane Hamel 5 months ago

    Done!

    Whenever a string of the format ${font-awesome icon} is found in a dimension, it will be replaced with its corresponding icon. It's not quite conditional formatting, but with calculated fields, you can use icons in a similar way.

    So something like ${far fa-grin-tongue-wink fa-2x} will be replaced by the grin-tongue-wink smiley.


    Cool isn't it! :)

    0
    Fixed

    Transaction refund / reverse not working ?

    Christopher Guillou 6 months ago in Analytics • updated by Stéphane Hamel 3 months ago 24

    When I try to cancel a transaction with the (awesome) new function I keep going through the Google Authorization every time process with no effect.

    Am I missing something ?

    Thanks !

    Answer
    Stéphane Hamel 3 months ago

    I have solved this problem by simplifying the way the data is retrieved and the measurement protocol call is created. This will be available in the next release, coming up very shortly.

    Also, I have introduced the ability to refund/revert a single item of a transaction.

    Note those features will eventually be available only to subscribers.

    0
    Fixed

    Images are not loading in GTM preview

    krvermeulen 7 months ago in Tag Manager • updated by Søren Friis Dam 6 months ago 4

    The images that are used in GTM Preview no longer work. See attached screenshot. The link to the images gives a 404.

    Example: https://www.davinci.tools/img/icons/ConversionLinker.png