0
Answered

Hide me does not work

Paul H. 2 months ago in Analytics • updated 4 weeks ago 9

I'm running into a problem that I cannot resolve and I can't find a posted description of the problem or the solution anywhere. I've my copy of the DaVinci in Google Analytics Tracking is set to "OFF" (Blocked).  When going to my website I see myself being tracked on GA "Real-time."  If I close the browser tab that I used to opened my website I continue to show up as a "real-time" user past the 30 second delayed response time.   If I close my Google Chrome browser, open it and the go directly to GA (nothing else), I'm still tracking as a real-time user. (?????)   The only way I found to remove myself from being tracked in real time on GA is to reboot my laptop. (????!!!!)   Got any ideas what could be causing this false real-time tracking??  Thank you....

Answer

Answer

I just checked again - worked fine for me. I also did a little Loom screen recording to show how it works/what happens: https://www.useloom.com/share/2781aa4b0a254c76a55ceeaa125598db

  • make sure you are NOT in Incognito mode - to respect user's privacy, Da Vinci doesn't work when the browser is in Incognito
  • does the Da Vinci Tools icon in the browser toolbar show a little red X?
  • if you can share your website, I can try to see if for some odd reason the GA call isn't being detected (you can email me@StephaneHamel.net to share the details)
  • if you open the browser JavaScript console, are there any errors?
  • if you enter chrome:extensions in your browser URL bar, it will show all your extensions and you can click on the background page for Da Vinci Tools - you will see messages like this:
Analytics.HideMe: Set to /id=(UA-570276-22)/
Analytics.HideMe: Blocked POST request matching /id=(UA-570276-22)/
Analytics.HideMe: Blocked GET request matching /id=(UA-570276-22)/
Analytics.HideMe: Set to /id=(^$)/
Under review

There are a couple of possibilities:

  1. an issue in the code when switching the "Hide me" switch on or off and it doesn't get handled by the background process;
  2. you are using two Chrome windows and are not signed in with the same user in Chrome so the preference isn't the same;
  3. some other weird problem...

Given rebooting will force Da Vinci to reload the preferences, I strongly suspect the problem is #1... I'm working on the next release so I will put that as a bug and check into it shortly.


I have an update to report.  Earlier I said that I had to reboot my laptop to erase myself from being tracked on GA.  I found that if I wait at least 7 minutes I am usually removed from "Real-Time" tracking.  On occasion it took up to 10 minutes (so far) before I'm removed from real-time tracking.  I hope this correction helps to identify the actual problem.

Regarding the possible problems, I am not signed in as more than one user nor do I have two windows.  I only have one google account andon occasion I am using more than one tab that is because I right-click an choose "open in a new tab."  This is all under the same account. Therefore (2.) cannot be the problem either. I'm thinking #1.

Answered

You were right, the GA Hide Me feature wasn't working. It's fixed in the next release, coming up very soon.

I received your update recently (3/30/19) however there seems to be no difference in performance.  GA is still tracking my presence whether I'm on my website as a visitor or if I go to my website through the WP admin dashboard.  Once detected, I need to be away from my website for 6-8 minutes before GA will stop recording my presence.  The issue is if I am doing any website page editing (changes, additions, removals, etc.) I cannot view what the edited page looks like without triggering GA tracking. I thought I was to remain in stealth mode even while I'm on my website. What am I doing wrong??


Just to make sure I've set things the right way, Google Analytics tracking toggle must be set to "blocked."  That is all that's required, there is no code that must be added to any of the WordPress "Theme Editor" files. Correct???

The effect should be immediate the next time you load a page on your website. It was indeed broken but I diid a bunch of tests and I thought it was ok - let me double check that again. So your scenario is you have GA open in one tab and you enable the "Hide Me" feature and you look at your real-time, and you have your website or WP admin open in another tab. It *should* work... but I will check again.

Answer

I just checked again - worked fine for me. I also did a little Loom screen recording to show how it works/what happens: https://www.useloom.com/share/2781aa4b0a254c76a55ceeaa125598db

  • make sure you are NOT in Incognito mode - to respect user's privacy, Da Vinci doesn't work when the browser is in Incognito
  • does the Da Vinci Tools icon in the browser toolbar show a little red X?
  • if you can share your website, I can try to see if for some odd reason the GA call isn't being detected (you can email me@StephaneHamel.net to share the details)
  • if you open the browser JavaScript console, are there any errors?
  • if you enter chrome:extensions in your browser URL bar, it will show all your extensions and you can click on the background page for Da Vinci Tools - you will see messages like this:
Analytics.HideMe: Set to /id=(UA-570276-22)/
Analytics.HideMe: Blocked POST request matching /id=(UA-570276-22)/
Analytics.HideMe: Blocked GET request matching /id=(UA-570276-22)/
Analytics.HideMe: Set to /id=(^$)/

Your understanding of my situation is correct.  According to the Chrome extensions page none of my extensions are set to allow incognito mode.  The icon is NOT "XED" out. I will send you my webpage through Email.  If I go to chrome://inspect/#extensions and "inspect" the DaVinci extension I get:   (Note the error message at the bottom).  How do I get to the information you've posted?  There is no "background page" button on any of my extensions including DaVinci, just "Details" and "Remove" buttons.  There isn't a background button/option under the "Details" window either.

background.js:60 Console was cleared
background.js:60 Da Vinci Tools by Stephane Hamel
background.js:60 Copyright Immeria Consulting Services Inc. 2017-2019. All rights reserved.
background.js:60
background.js:64 Analytics.HideMe: Listening for requests matching undefined
background.js:66 TagManager.HideMe: Listening for requests matching undefined
background.js:72 Checking first install or updates
background.js:74 Retrieving preferences: Object
background.js:61 Analytics.HideMe: Listening for rules changes.
background.js:61 TagManager.HideMe: Listening for rules changes.
background.js:61 Analytics.HostPrefix: Listening for popup requests.
background.js:68 Analytics.RememberMe: Listening for requests.
background.js:69 TagManager.RememberMe: Listening for requests.
background.js:71 Analytics.RememberMe: Listening for new starting URLs.
background.js:71 TagManager.RememberMe: Listening for new starting URLs.
background.js:74 All done.
background.htm:1 Error in event handler: TypeError: Cannot read property 'state' of undefined
at Object.success (chrome-extension://pekljbkpgnpphbkgjbfgiiclemodfpen/js/background.js:73:477)
at chrome-extension://pekljbkpgnpphbkgjbfgiiclemodfpen/vendor/buy.js:1:397

Ah! That will help - let me check that!

+1

That last upgrade did it.  It's working! Thanks for fixing it!