0
Fixed

Can't access other logged profiles in GTM (Chrome) it always redirect to the default user

Carlos Escalera Alonso 6 months ago in Tag Manager updated by Stéphane Hamel 1 month ago 10

I noticed this yesterday, when I was trying to switch to another logged user in Chrome, GTM kept redirecting me to the default user. I had to disable the extension momentarily to be able to change

UPDATE: the issue disappears when I disable the option "RememberMe: Remember last container you were on"

Answer

+1
Answer
Fixed

Fixed in the upcoming release.

GOOD, I'M SATISFIED
Satisfaction mark by Carlos Escalera Alonso 6 months ago

I have experienced the same thing.  It is the nature of remembering the last container you are on.  This feature is great when you are consistently within a single account, but as you have seen, not appropriate if you are constantly going from account to account.   
It performs as it should, it is trying to point to your last container, you just aren't logged in to see it.

Started

Ah! Yes, this is certainly related to Remember Me! I will test and fix for the next release.

I will try to detect if switching to a different account and proceed normally.

+1

To help me out with the repro-steps and make sure I got it right:

  1. You are logged in with user A
  2. You click on your user icon to bring the list of user accounts and click on a different one
  3. GTM brings you back to your latest URL with the initial user - dismissing completely your latest selection

To solve this, I will do the Remember Me per account (and also in GA)

+1
Answer
Fixed

Fixed in the upcoming release.

Not sure if the new release is already out, but tThis is still an issue for me on the Brave browser. GTM reverts to the default account. No problem with GA. Version 2019.7.26

Under review

Honestly, I have never tested with Brave - I will have to check, but if Brave restricts localStorage or other things, it might not work.

Started

I just tested with Brave and for me, it works fine when I switch account using the drop-down menu available under the GA account - it brings me back to the default GA home page. Unless I'm missing something?

+1

Under GA it works fine for me, but when trying it from GTM it doesn't work. I've turned off the setting that remembers the last container and now it works fine, so it's not a big deal.

+1
Fixed

Fixed for next release.

Ok, I will check this out. I also did some tests with Brave and so far so good!